Schlagwort-Archive: CCH0123F1-Z03A

Keysite Oszilloskop stirbt im Standby – Netzteilreparatur

Ein interessantes Problem ist bei der Messtechnik in den Labors meines Arbeitsplatzes aufgetreten. Mit „Messtechnik“ bezeichne ich die Ausstattung eines Laborarbeitsplatzes, für die Grundlagenausbildung. Von den Laborarbeitsplätzen gibt es insgesamt neunzehn Einheiten, die mit je zwei Labornetzgeräten, zwei Tischmultimetern, einem Keysite Signalgenerator und einem Keysite (Agilent) Oszilloskop der Serie Infiniivision DSO-X 20xx ausgerüstet sind. Alle Geräte sind netzwerkfähig und sind über LAN mit dem zugehörigen Arbeitsplatzrechner verbunden. So kann mit Hilfe unterschiedlicher Software (Agilent VEE, Matlab, LabVIEW etc.) auf die Messgeräte zugegriffen werden. Die Geräte wurden vor ca. drei Jahren angeschafft und ersetzt die fast zwanzig Jahre alte Laborausstattung. 

Doch nun ist der Fall aufgetreten, dass bei einem Arbeitsplatz das DSO-X2012A Oszilloskop kein Lebenszeichen mehr von sich gab. Es kommt gelegentlich vor, dass bei Laborübungen oder beim freien Arbeiten in den Labors einmal ein Studierender den Not-Aus Schalter des Arbeitsplatzes betätigt und ihn so stromlos macht.  Doch das war nicht der Fall. Alle an dem Arbeitsplatz angeschlossenen Geräte funktionierten, mit Ausnahme des DSO. Auch am Ende des Kaltgerätesteckers war Spannung zu messen. Also konnte das Problem nur am Oszilloskop selber liegen. Die Rückwand ist schnell abgeschraubt, ein Schirmblech entfernt und das Netzteil liegt frei. Gleich bei der ersten optischen Begutachtung ist der große Siebelko mit nach oben gewölbter Kappe aufgefallen. Aber einmal schön der Reihe nach.

Netzteil des Infiniivision

An den AC Pins vom Netzeingang war die Netzspannung zu messen, jedoch an keinem der Ausgänge des Netzteils eine Gleichspannung. Egal ob der Powerschalter des Gerätes ein- oder ausgeschaltet war. Die Vermutung liegt nahe, dass das Netzteil defekt ist.

Eingangssicherung

Zunächst wurde das Netzteil ausgebaut und beginnend von der AC-Eingangsseite untersucht. Die Printsicherung im Bereich des Netzfilters ist gleich als erstes defektes Bauteil aufgefallen. Es handelt sich um eine träge 6.3A/250V Sicherung. Da eine ausgelöste Sicherung immer einen Grund hat, abzuschalten, wurde weitergesucht. Die Netzgleichrichter waren ok, jedoch hatte der 100uF / 420V Elektrolytkondensator, der als Gleichspannungsglättung der Primärseite eingesetzt ist, thermisch schon einiges abbekommen und war aufgebläht.

originaler Elko 100uF /420V /105°C

Auch seine Kapazität war nicht mehr im Nominalbereich. Aber auch das war nicht direkt der Grund für das Auslösen der Sicherung. Der war dann schnell gefunden. Ein Mosfet der als Ansteuerung des Transformators dient, war niederohmig. Genauer gesagt er hatte einen Kurzschluss zwischen allen Anschlüssen.

Mosfet STP12NM50

Das folgende Bild zeigt die Einbaupositionen der Bauteile. Diese wurden erneuert. Der Mosfet wurde durch einen Originaltyp ersetzt und der Netzelko gegen einen 100uF / 450V /105°C Typ getauscht. Der ist zwar von der Bauhöhe etwa fünf Millimeter höher, passt aber problemlos in das Netzteil.

Einbaulage des Kondensators und des Mosfet

Auf der Rückseite der Netzteilplatine waren zwei SMD Widerstände im Bereich des Gate-Anschlusses des Mosfet defekt. Es handelt sich dabei um einen SMD Widerstand der Baugröße 0805 mit 5,11 Ohm und einen SMD Widerstand der Baugröße 1206 mit 2,0 kOhm. Das untenstehende Bild zeigt auch hier wieder die Einbaulage.

Einbaulage der defekten SMD Widerstände

Nachdem alle erwähnten Bauteile erneuert waren, wurde ein erster Funktionstest durchgeführt. Dieser war jedoch ernüchternd, denn das Netzteil arbeitete noch nicht. Die Sicherung blieb intakt und die primärseitige Gleichspannung stand stabil. Doch das Gate des Mosfet wurde nicht angesteuert – leider. Denn jetzt kam der aufwendige Teil der Reparatur. Auf der Netzteilplatine befindet sich, stehend eingebaut, eine weitere Platine, auf der mehrere Controller IC´s verbaut sind. Verfolgt man die Gate-Leitung vom Mosfet, so endet sie an einem Pin dieser Ansteuerungsplatine. Also muss diese raus.

Controllerboard ausgebaut

Dazu musste zuerst das Kühlblech entfernt werden. Dann wurde es etwas mühsam, denn das Controllerboard ist nicht über eine Stiftleiste oder Steckverbindung mit der Hauptplatine verbunden, sondern die Kontaktpins sind gelayoutet und ausgefräst. Das bedeutet, man muss die Auslötarbeiten sehr behutsam in Angriff nehmen, um die Leiterbahnen an den Enden der gefrästen Pins nicht zu beschädigen.

Mainboard ohne Controllerplatine

 

UC3842B

Als der Ausbau erfolgreich abgeschlossen war, konnte das Controllerboard begutachtet werden. Und siehe da, die vom Gate des Mosfet geroutete Leitung endet an Pin 6 eines kleinen IC´s. Dabei handelt es sich um einen UC3842B VD1R2G. Bei diesem IC war das Gehäuse gesprengt. Neben dem Controller IC, war auch ein SOT23 PNP-Transistor (PMBT 2907A) gestorben und an allen Pins niederohmig.

Einbaulage der defekten Komponenten

Nach dem Erneuern der defekten Komponenten, wurde das Netzteil wieder zusammengebaut und ein Funktionstest durchgeführt. Das Oszilloskop startete wieder und das Netzteil verrichtete seinen Dienst.

defekte Bauteile
Ergebnis nach erfolgter Reparatur

Interessant wäre es jetzt herauszufinden, warum das Netzteil nach gerade einmal drei Jahren seinen Geist aufgibt. Zumal die Oszilloskope nicht im Dauerbetrieb laufen, sondern nur während der entsprechenden Lehrveranstaltungen eingeschaltet sind. Dabei ist folgendes aufgefallen: Das Oszilloskop ist permanent an die Stromversorgung angeschlossen. Der Power-Schalter des Oszilloskops schaltet aber nicht die AC-Versorgung aus, sondern nur im Sekundärbereich des Netzteils die Controlleransteuerung. Das bedeutet, das Netzteil arbeitet im ausgeschalteten Zustand quasi im Standby-Betrieb. Und dabei ist uns aufgefallen, dass bei allen ausgeschalteten Oszilloskopen im Standby eine Verlustleistung auftritt, die die Mosfets und vor allem den 100uF Elko stark erwärmt. Das würde den aufgebähten, ausgetrockneten Elko und den darauffolgenden Tod der Netzteile erklären.  Um das zu verifizieren wurde bei mehreren Geräten die seit Tagen nicht eingeschaltet waren, die Temperatur an den Komponenten gemessen.

 
Thermofühler an der Elkooberfläche

Hier konnte folgendes festgestellt werden. Sowohl an der Oberfläche des Kondensators als auch am Kühlblech der Mosfets waren im ausgeschalteten Zustand Temperaturen von 56°C bis knapp 60°C zu messen.  Sollte das so sein ??

Temperaturmessung am Elektrolytkondensator

 

Hier noch die benötigten Bauteile:

  • Widerstand 5R11 0,1W 0,1% Farnell Nr.: 614-4257
  • Widerstand 2k0 0.66W Farnell Nr.: 721-9844
  • PNP Transistor SOT23, SMD Stempel 2F Type PMBT2907A, 215 Farnell Nr.: 1626500
  • PWM Controller IC, UC3842B VD1R2G / 500kHz Farnell Nr.: 2835218
  • Kondensator 100uF / 105°C / 450V
  • Printsicherung T6.3A 250V